Explorer is not working

Incident Report for Tenderly

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 17:19 UTC

Identified

Explorers and project transaction listing are not working at the moment. The team is working on resolving the issue.
Posted Apr 08, 2025 - 13:45 UTC
This incident affected: Explorer.