Missing block range on Polygon and Polygon xxplorer lag

Incident Report for Tenderly

Resolved

All issues have been resolved. Polygon is fully in sync now and missing blocks have been backfilled.
Posted Oct 28, 2025 - 10:57 UTC

Monitoring

Alerts and Web3 Actions are experiencing delays for the block range [78,266,299 – 78,266,736].
Our team is actively backfilling the affected blocks to ensure that no alerts or Web3 Actions are skipped — only delayed.
The team is also working on resolving Node RPC, Simulator and Explorer delays.

We appreciate your patience and apologize for the inconvenience.
Posted Oct 28, 2025 - 09:39 UTC

Identified

We are currently experiencing missing block ranges on the Polygon network, affecting the Node RPC, Simulator, and Alerts services. The Polygon explorer is also experiencing delays.

Our team is actively investigating and working to resolve the issue. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Oct 28, 2025 - 08:51 UTC
This incident affected: Polygon (Node, Explorer, Simulator, Alerts, Web3 Actions).