Polygon Node Lag

Incident Report for Tenderly

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 22:18 UTC

Monitoring

A fix has been implemented and both networks (Polygon & Polygon Amoy) have no lag at the moment.

The team will continue to monitor the status for a while.
Posted Apr 09, 2026 - 21:23 UTC

Identified

Team has identified the issue on Polygon Mainnet with lag dropping.

Polygon Amoy lag continues to rise, and the team is continuing the investigation.
Posted Apr 09, 2026 - 20:43 UTC

Investigating

We have identified our Polygon Mainnet nodes are lagging by ~1500 blocks as well as our Polygon Amoy by ~3000 blocks.

Team is working on investigating the issue.
Posted Apr 09, 2026 - 19:50 UTC
This incident affected: Polygon (Virtual Testnet, Explorer, Simulator, Alerts, Web3 Actions, Node RPC) and Polygon Amoy (Virtual Testnet, Explorer, Simulator, Alerts, Web3 Actions, Node RPC).