Monitoring Lag - Alert and Action Notifications

Incident Report for Tenderly

Resolved

We've confirmed that the elevated lag affecting Web3 Actions and Alerting has fully cleared. All systems are back to normal operation and performing as expected.
Posted Jun 25, 2026 - 17:20 UTC

Monitoring

Monitoring — 16:57 UTC

Recovery is progressing. The alert delivery backlog has decreased significantly and continues to clear. We are monitoring until full recovery is confirmed.

Delayed notifications will be delivered automatically — no action is required on your end.
Posted Jun 25, 2026 - 15:31 UTC

Update

Identified — 16:30 UTC

We have identified the cause: a significant surge in transaction volume on Base, Monad, and Arbitrum Sepolia caused a backlog in our alerting pipeline.
End-to-end alert delivery latency peaked at approximately 7 minutes.

All networks are affected as our alerting pipeline is shared. Traffic is now normalizing and latency is slowly decreasing.
Posted Jun 25, 2026 - 15:30 UTC

Update

We are continuing to investigate this issue.
Posted Jun 25, 2026 - 15:28 UTC

Investigating

Investigating — 15:58 UTC

We have noticed a performance degradation on our alerting system starting 15:58 UTC.
Alert and action-triggered notifications are delayed across all networks. Slack, Telegram, and email alerts are operational.
Posted Jun 25, 2026 - 15:28 UTC
This incident affected: Monad (Alerts), Arbitrum Sepolia (Alerts), and Base (Alerts).