Ethereum Sepolia RPC experiencing issues

Incident Report for Tenderly

Resolved

The incident has been resolved and we are serving traffic trough Sepolia RPC again.
Posted May 16, 2025 - 19:14 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 16, 2025 - 19:12 UTC

Identified

We're having issues on Ethereum Sepolia RPC at the moment so you might experience increase in errors. The team is working on the fix.
Posted May 16, 2025 - 13:43 UTC
This incident affected: Node.