Explorer and Monitoring (Alerts and Web3 Actions) have been fully restored. All components are now operating normally and the incident has been resolved.
Posted Apr 02, 2026 - 19:06 UTC
Monitoring
We are pleased to report that Node RPC, Virtual Testnets, Simulations, and Debugger have been restored and are operating normally.
Our team is actively working to resolve the remaining issues affecting the following components: - Explorer - Monitoring (Alerts and Web3 Actions)
We will provide a further update once these components have been fully restored. We apologize for the continued inconvenience.
Posted Apr 02, 2026 - 19:01 UTC
Identified
We're currently experiencing lag on Taiko Mainnet network that's affecting all features. The team is working on resolution and we'll keep you posted on all updates.