Degraded Performance - Arbitrum Sepolia

Incident Report for Tenderly

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 09:45 UTC

Monitoring

The nodes are back in sync, we will continue to monitor the network health.
Posted Oct 16, 2025 - 07:18 UTC

Identified

We are experiencing lag on Arbitrum Sepolia network.

The Arbitrum Sepolia network has stalled at block 204926534
https://sepolia.arbiscan.io/block/204926534

We're currently working with the Arbitrum team to fix the issue.
Posted Oct 15, 2025 - 16:58 UTC